Search found 249 matches

by bast
02 Feb 2014, 22:06
Forum: Installing Dalton
Topic: CMake Not Detecting MKL on Systems
Replies: 6
Views: 9889

Re: CMake Not Detecting MKL on Systems

hi John, how did you configure? what was the setup command?
have you set MATH_ROOT?
by bast
16 Jan 2014, 18:04
Forum: Bug reports
Topic: NEVPT2 calculations
Replies: 3
Views: 11882

Re: NEVPT2 calculations

by default i would go for 32bit integers because it's better tested and better supported by MPI and math libs. but sometimes you have no other choice and this could be such a case. in principle nothing wrong with 64bit integer binaries but one has to be careful with math libraries (not all can cope ...
by bast
16 Jan 2014, 17:49
Forum: Bug reports
Topic: NEVPT2 calculations
Replies: 3
Views: 11882

Re: NEVPT2 calculations

hi Max,
i know nothing about that code part but the "negative" integer indicates
that some integers become too large to fit into 32 bits and wrap around.
i would compile for 64bit integers and see what happens:

Code: Select all

./setup --int64 ...
good luck!
radovan
by bast
14 Jan 2014, 16:23
Forum: Installing Dalton
Topic: Testing the installation
Replies: 4
Views: 7283

Re: Testing the installation

try also "man ctest" there are very many options ...
by bast
14 Jan 2014, 16:04
Forum: Installing Dalton
Topic: Testing the installation
Replies: 4
Views: 7283

Re: Testing the installation

yes you can do it (start, end, stride):
$ ctest -I 200,300,1
you can also run them on several cores with -jN.
by bast
06 Jan 2014, 11:12
Forum: Installing Dalton
Topic: Syntax error??
Replies: 8
Views: 14861

Re: Syntax error??

just a comment: you should not give the link path through the --extra flags. this works but it is ugly. you should set the link path by exporting LD_LIBRARY_PATH or even better by using the compilervars.sh script that comes with the Intel compilers: my .bashrc contains: source /opt/intel/bin/compile...
by bast
26 Dec 2013, 15:14
Forum: Bug reports
Topic: The output file of Dalton2013.1 still read patch 0
Replies: 1
Views: 6794

Re: The output file of Dalton2013.1 still read patch 0

thanks Ariel - we will correct this for future patches.
by bast
19 Dec 2013, 19:14
Forum: Announcements
Topic: DALTON 2013.1 patch
Replies: 0
Views: 8192

DALTON 2013.1 patch

Dear Dalton users, we have collected a number of fixes and improvements into the 2013.1 patch: - Correct the printout of relativistic corrections to the shielding (thanks to M. Jaszunski). - Compilation fix for DALTON/abacus/rma_windows.F90 (Intel 10.0.011). - Fix of error where basis set names were...
by bast
16 Dec 2013, 10:38
Forum: Installing Dalton
Topic: Problem with int64
Replies: 2
Views: 6519

Re: Problem with int64

hi Yurij and Kirk, I think that Dalton is not as thoroughly tested for 64bit integers with MPI as it is for 32bit integers with MPI. personally I would avoid the default 64bit integers unless you have a very good motivation for it (like a calculation that is impossible to run with 32bit integers). A...
by bast
02 Dec 2013, 17:42
Forum: Installing Dalton
Topic: errors installing on SGI Altix 350 Dalton 2013.0
Replies: 10
Views: 64403

Re: errors installing on SGI Altix 350 Dalton 2013.0

does your MPI implementation support the MPI-2 standard?
MPI_Type_get_extent is to my knowledge not available in MPI-1.1.
by bast
02 Dec 2013, 11:57
Forum: Running Dalton
Topic: combine functional in DALTON2013
Replies: 6
Views: 7928

Re: combine functional in DALTON2013

Thanks. So then I should recompile Dalton2013 with "-DDISABLE_XC_RESPONSE_SANITY_CHECK"? For some organometallic compounds, B3LYP or CAMB3LYP gave very low excitation energy, while B3PW91 gave comparable one as GAUSSIAN does. you can disable this check with: ./setup [--other flags] -D CPP="-DDISABL...
by bast
02 Dec 2013, 09:56
Forum: Running Dalton
Topic: combine functional in DALTON2013
Replies: 6
Views: 7928

Re: combine functional in DALTON2013

see also this message: note that GGAKEY functionals are always stopped although they could be correct this happens because we are very conservative there. if you are sure that the individual functionals work, then also the Combine/GGAKEY should work. in other words you will see this error for any Co...
by bast
27 Nov 2013, 21:17
Forum: Installing Dalton
Topic: errors installing on SGI Altix 350 Dalton 2013.0
Replies: 10
Views: 64403

Re: errors installing on SGI Altix 350 Dalton 2013.0

If amfi.F is so hard to compile with optimization, perhaps it should be split into multiple files that are easier for the compiler to swallow. We have such issues in NWChem and I just split the code. Resorting to -O0 should be reserved for exceptional cases and only done to the exact set of subrout...
by bast
27 Nov 2013, 19:24
Forum: Installing Dalton
Topic: errors installing on SGI Altix 350 Dalton 2013.0
Replies: 10
Views: 64403

Re: errors installing on SGI Altix 350 Dalton 2013.0

thanks Marc for the confirmation. i will apply the change to the repository. it will be part of 2013.1 patch. about amfi.F: a possible workaround will be to lower compiler optimization for this one file (while keeping it for all other files). for this edit cmake/compilers/FortranFlags.cmake and inse...
by bast
27 Nov 2013, 19:19
Forum: Installing Dalton
Topic: LSDALTON 2013: Make Error - missing 'interest' folder
Replies: 2
Views: 4831

Re: LSDALTON 2013: Make Error - missing 'interest' folder

dear Rainer, from the error i suspect that you compile LSDALTON using the configure script and the Makefile. the recommended compilation is however via CMake. it is very likely that you have lsdalton.x compiled already along dalton.x. by default both executables are compiled. if this is the case you...
by bast
25 Nov 2013, 22:34
Forum: Installing Dalton
Topic: errors installing on SGI Altix 350 Dalton 2013.0
Replies: 10
Views: 64403

Re: errors installing on SGI Altix 350 Dalton 2013.0

cozzi wrote:Thank you for the fast response!

do I need to do a make clean and the whole ./setup thing again?

regards,

--marc
no you don't need to make clean or re-setup. just edit the file,
go back to the build directory and type "make". it should resume where it stopped.
by bast
25 Nov 2013, 22:10
Forum: Installing Dalton
Topic: errors installing on SGI Altix 350 Dalton 2013.0
Replies: 10
Views: 64403

Re: errors installing on SGI Altix 350 Dalton 2013.0

hi Marc, there is nothing wrong with the compiler. can you please try to replace the line 43 in file DALTON/abacus/rma_windows.F90. type rma_win by type, public :: rma_win please let me know if this worked, in that case i will also correct it in the repository so that it gets into 2013.1. radovan
by bast
25 Nov 2013, 10:13
Forum: Running Dalton
Topic: Parallel run error
Replies: 12
Views: 15195

Re: Parallel run error

No. What version GLIBC is required? i cannot answer this question. is it possible that there is something wrong with the OpenMPI installation? are you able to compile and run other programs with this installation? the MPI error that you see means that either sending and receiving calls are not matc...
by bast
22 Nov 2013, 14:36
Forum: Bug reports
Topic: Basis set label problem
Replies: 2
Views: 9728

Re: Basis set label problem

thank you for the bug report. i can confirm this.
we will look into the problem. a workaround in the meantime is to run without MPI -
in a sequential calculation this problem does not appear. something is broken
when transmitting basis set information to the worker processes.
by bast
19 Nov 2013, 10:13
Forum: Bug reports
Topic: relativistic corrections to the shielding
Replies: 2
Views: 8279

Re: relativistic corrections to the shielding

dear Michal,
thank you for the report and a solution at the same time.
i am correcting it in the release branch. this will be part of the 2013.1 patch.
best regards,
radovan
by bast
15 Nov 2013, 09:55
Forum: Running Dalton
Topic: Parallel run error
Replies: 12
Views: 15195

Re: Parallel run error

calculation stops on "Starting in Integral Section" and gives the same error. have a look at the dalton script: /gpfs/CLUSTERUSERS/neilparker2/soft/DALTON-2013.0-Source/build/dalton look for the line MPIRUN= at the beginning of the script. does it point to the right mpirun? were you able to solve t...
by bast
13 Nov 2013, 12:13
Forum: Running Dalton
Topic: Parallel run error
Replies: 12
Views: 15195

Re: Parallel run error

avelon wrote:calculation stops on "Starting in Integral Section" and gives the same error.
have a look at the dalton script:
/gpfs/CLUSTERUSERS/neilparker2/soft/DALTON-2013.0-Source/build/dalton
look for the line MPIRUN= at the beginning of the script.
does it point to the right mpirun?
by bast
13 Nov 2013, 10:37
Forum: Running Dalton
Topic: Parallel run error
Replies: 12
Views: 15195

Re: Parallel run error

hi, i suggest take a simple dal file: **DALTON INPUT .RUN WAVE FUNCTIONS **WAVE FUNCTIONS .DFT B3LYP **END OF DALTON INPUT and a simple mol file: BASIS cc-pVDZ C 1 10. 1 Ne 0.0 0.0 0.0 run this with MPI with default memory (don't specify any memory). this calculation "has to work" and it takes 1 sec...
by bast
26 Aug 2013, 13:26
Forum: Installing Dalton
Topic: Installation of Dalton2013
Replies: 0
Views: 5790

Installation of Dalton2013

Dalton is configured using CMake, typically via the setup script,
and subsequently compiled using make or gmake:

Code: Select all

  $ ./setup [--flags]
  $ cd build
  $ make
To see all options, run:

Code: Select all

  $ ./setup --help
You can find detailed instructions on this page: http://daltonprogram.org/installation/2013