Molden input file in Jmol

This section is no longer in use. If you found a bug, please file an issue on the Dalton or LSDalton GitLab.
Posts: 600
Joined: 15 Oct 2013, 05:37
First name(s): Peter
Middle name(s): Robert
Last name(s): Taylor
Affiliation: Tianjin University
Country: China

Molden input file in Jmol

Post by taylor » 16 Jul 2018, 02:41

I have encountered what is at least an idiosyncrasy, if not some type of bug, when reading the Molden input file generated by a Dalton run into Jmol. (I do this because the MO display is much nicer in Jmol than in Molden). If the file generated by Dalton contains a [GEOCONV] section, listing the energies for each step of an optimization, then Jmol produces an error when trying to read the file. If I simply delete this section in its entirety, Jmol reads the file without problems. It does not matter where in the file the [GEOCONV] section appears --- I have tried moving it and achieved nothing.

Why do I post this as a Dalton issue when at first sight it appears to be a Jmol problem? Because if I take a Molden input generated by another quantum chemistry program, then the problem does not arise. Both files contain [GEOCONV] sections, both are the same molecule. It is true that the format of the step-by-step energy numbers in the GEOCONV section is different between the two files, but I have tried converting the Dalton-generated numbers to the same format as the other code, and this does not help in the slightest. Nor does replacing the [GEOCONV] section of the file that does not work with the section from the one that does. I have also checked for any strange whitespace such as tabs or extra spaces at the end of lines, and this does not appear to be the problem either.

Has anyone else seen this behaviour?

Best regards


Who is online

Users browsing this forum: No registered users and 1 guest