Syntax error??

Problems with Dalton installation? Find answers or ask for help here
Post Reply
aplicacions
Posts: 3
Joined: 03 Jan 2014, 09:06
First name(s): Aplicaciones
Last name(s): CESGA
Affiliation: Supercomputing
Country: Spain

Syntax error??

Post by aplicacions » 03 Jan 2014, 09:24

Hi:

I'm trying to install DALTON 2013.1 with OpenMP support.

I'm using icc/ifort version 14.0 and intel MLK 11.1.

My setup command is:

Code: Select all

./setup --cxx=gcc --fc=gfortran --cc=gcc --int64 --omp --prefix=$HOME/dalton-local.omp --mkl=parallel --extra-fc-flags="-L/opt/intel/composer_xe_2013_sp1.0.080/mkl/lib/intel64" --extra-cc-flags="-L/opt/intel/composer_xe_2013_sp1.0.080/mkl/lib/intel64" --extra-cxx-flags="-L/opt/intel/composer_xe_2013_sp1.0.080/mkl/lib/intel64 "
After setup,:

Code: Select all

cd build
make -j 4
But, after a time, I'm getting this error message:

Code: Select all

.......
.......
[ 84%] Building Fortran object CMakeFiles/lsintlib.dir/LSDALTON/LSint/ThermiteDriver.F90.o
/mnt/EMC/Home_SVG/home/ulc/es/rdl/DALTON-2013.1-Source.omp/LSDALTON/LSint/ThermiteDriver.F90(219): error #5082: Syntax error, found 'ALLOC' when expecting one of: <IDENTIFIER> <CHAR_CON_KIND_PARAM> <CHAR_NAM_KIND_PARAM> <CHARACTER_CONSTANT> /
!$OMP IRHSTMP) SHARED(sharedTUV,Alloc,Input,OD_LHS,OD_RHS,nOverlapOfPassType,PassTypeOverlapIndex,&
--------------------------------^
/mnt/EMC/Home_SVG/home/ulc/es/rdl/DALTON-2013.1-Source.omp/LSDALTON/LSint/ThermiteDriver.F90(1337): error #5082: Syntax error, found 'ALLOC' when expecting one of: <IDENTIFIER> <CHAR_CON_KIND_PARAM> <CHAR_NAM_KIND_PARAM> <CHARACTER_CONSTANT> /
!$OMP maxOrb) SHARED(sharedTUV,Alloc,Input,OD_LHS,OD_RHS,&
-------------------------------^
/mnt/EMC/Home_SVG/home/ulc/es/rdl/DALTON-2013.1-Source.omp/LSDALTON/LSint/ThermiteDriver.F90(1883): error #5082: Syntax error, found 'ALLOC' when expecting one of: <IDENTIFIER> <CHAR_CON_KIND_PARAM> <CHAR_NAM_KIND_PARAM> <CHARACTER_CONSTANT> /
!$OMP Alloc,OD_LHS,OD_RHS,iprint,lupri,sharedTUV,nOverlapOfPassType,&
------^
compilation aborted for /mnt/EMC/Home_SVG/home/ulc/es/rdl/DALTON-2013.1-Source.omp/LSDALTON/LSint/ThermiteDriver.F90 (code 1)
make[3]: *** [CMakeFiles/lsintlib.dir/LSDALTON/LSint/ThermiteDriver.F90.o] Error 1
make[2]: *** [CMakeFiles/lsintlib.dir/LSDALTON/LSint/ThermiteDriver.F90.o.provides] Error 2
make[1]: *** [CMakeFiles/lsintlib.dir/all] Error 2
make: *** [all] Error 2
The error message talk about a disturbing "error #5082: Syntax error".....

Any ideas about this issue??

Best regards.

tkjaer
Posts: 300
Joined: 27 Aug 2013, 20:35
First name(s): Thomas
Last name(s): Kjaergaard

Re: Syntax error??

Post by tkjaer » 03 Jan 2014, 09:30

./setup --cxx=gcc --fc=gfortran --cc=gcc means that you want to compile using gfortran and gcc NOT icc/ifort version 14.0 as you claim.

try

./setup --cxx=icpc --fc=ifort --cc=icc --int64 --omp --prefix=$HOME/dalton-local.omp --mkl=parallel --extra-fc-flags="-L/opt/intel/composer_xe_2013_sp1.0.080/mkl/lib/intel64" --extra-cc-flags="-L/opt/intel/composer_xe_2013_sp1.0.080/mkl/lib/intel64" --extra-cxx-flags="-L/opt/intel/composer_xe_2013_sp1.0.080/mkl/lib/intel64 "

instead

aplicacions
Posts: 3
Joined: 03 Jan 2014, 09:06
First name(s): Aplicaciones
Last name(s): CESGA
Affiliation: Supercomputing
Country: Spain

Re: Syntax error??

Post by aplicacions » 03 Jan 2014, 09:50

Sorry:
I made a mistake with the C&P

I meant:

Code: Select all

./setup --cxx=icc --fc=ifort --cc=icc --int64 --omp --prefix=$HOME/dalton-local.omp --mkl=parallel --extra-fc-flags="-L/opt/intel/composer_xe_2013_sp1.0.080/mkl/lib/intel64" --extra-cc-flags="-L/opt/intel/composer_xe_2013_sp1.0.080/mkl/lib/intel64" --extra-cxx-flags="-L/opt/intel/composer_xe_2013_sp1.0.080/mkl/lib/intel64"
I also (as you can see due my C&P mistake) attempt by use GCC instead... but it seems to have problems with the MKL...

I will probe to use "--cxx=icpc" instead "--cxx=icc" as you say...

Thanks

tkjaer
Posts: 300
Joined: 27 Aug 2013, 20:35
First name(s): Thomas
Last name(s): Kjaergaard

Re: Syntax error??

Post by tkjaer » 03 Jan 2014, 09:58

It is not a syntax error - I suspect that the ifort 14.0 is crap as usual - (ifort 12.1, 13.1, 14.1 is usually much better than ifort 12.0, 13.0, 14.0)

The problem occurs in LSDALTON - if you only need DALTON and do not need LSDALTON a quick fix would be to use

make dalton.x

instead of

make

to only build DALTON.

when using gcc and MKL I suggest to use auto detection.

just

export MATH_ROOT=/opt/intel/composer_xe_2013.5.192/mkl

and do

./setup --cxx=gcc --fc=gfortran --cc=gcc --int64 --omp --prefix=$HOME/dalton-local.omp

or whatever your path is

aplicacions
Posts: 3
Joined: 03 Jan 2014, 09:06
First name(s): Aplicaciones
Last name(s): CESGA
Affiliation: Supercomputing
Country: Spain

Re: Syntax error??

Post by aplicacions » 03 Jan 2014, 13:55

Great!!

It works with the 12.1 version of icc/ifort (changing the paths in the xx-flags options, of course)

Thanks you very much.

bast
Posts: 1210
Joined: 26 Aug 2013, 13:22
First name(s): Radovan
Last name(s): Bast
Affiliation: none
Country: Germany

Re: Syntax error??

Post by bast » 06 Jan 2014, 11:12

just a comment: you should not give the link path through the --extra flags.
this works but it is ugly. you should set the link path by exporting LD_LIBRARY_PATH
or even better by using the compilervars.sh script that comes with the Intel compilers:
my .bashrc contains:
  • source /opt/intel/bin/compilervars.sh intel64
if you are on a cluster then there should be mechanisms in place (module load)
to set correct library paths.

bast
Posts: 1210
Joined: 26 Aug 2013, 13:22
First name(s): Radovan
Last name(s): Bast
Affiliation: none
Country: Germany

Re: Syntax error??

Post by bast » 11 Dec 2014, 15:30

i ran into the same problem (Intel 14.0.4 complaining about "Alloc")
and then i found this: https://software.intel.com/en-us/forums/topic/501002
so it seems "Alloc" is an unfortunate name in combination with OMP. perhaps we should rename it?

tkjaer
Posts: 300
Joined: 27 Aug 2013, 20:35
First name(s): Thomas
Last name(s): Kjaergaard

Re: Syntax error??

Post by tkjaer » 11 Dec 2014, 16:31

The variable have been renamed shortly after the 2013 release.

A new release will fix the problem.

TK

bast
Posts: 1210
Joined: 26 Aug 2013, 13:22
First name(s): Radovan
Last name(s): Bast
Affiliation: none
Country: Germany

Re: Syntax error??

Post by bast » 11 Dec 2014, 16:33

thanks! indeed i was installing 2013.4

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests