Installing Dalton on Ubuntu

Problems with Dalton installation? Find answers or ask for help here
varuniitr
Posts: 69
Joined: 26 Mar 2014, 10:28
First name(s): Varun
Last name(s): Kundi
Affiliation: IIT Roorkee
Country: India

Re: Installing Dalton on Ubuntu

Post by varuniitr » 08 Jun 2014, 09:35

Sir how can we check the core dumped file and why it happens?

bast
Posts: 1210
Joined: 26 Aug 2013, 13:22
First name(s): Radovan
Last name(s): Bast
Affiliation: none
Country: Germany

Re: Installing Dalton on Ubuntu

Post by bast » 08 Jun 2014, 16:46

analyzing a core dump is possible but normally the last resort.
then you ask why it happens. this is impossible to answer
since i don't know what you have tried. you provide
no information here that i could use. please describe
what you have tried. perhaps attach an output file.

varuniitr
Posts: 69
Joined: 26 Mar 2014, 10:28
First name(s): Varun
Last name(s): Kundi
Affiliation: IIT Roorkee
Country: India

Re: Installing Dalton on Ubuntu

Post by varuniitr » 10 Jun 2014, 07:52

Radhovan Sir,
I am using nohup mpirun -np 8 Machinefile ./Hostfile /home/user/SOFT/DALTON/DALTON 2013.2 Source/build/dalton beta 10dft &
for running job on multinodes with 4 cores on each node. but job is getting failed. Is this script line correct? My job on single node with multocores is running. Job is running on local node but on other node it is not running. I am using Intel Cluster Studio. Please tell me solution.
Last edited by varuniitr on 10 Jun 2014, 08:12, edited 1 time in total.

varuniitr
Posts: 69
Joined: 26 Mar 2014, 10:28
First name(s): Varun
Last name(s): Kundi
Affiliation: IIT Roorkee
Country: India

Re: Installing Dalton on Ubuntu

Post by varuniitr » 10 Jun 2014, 08:10

bast wrote:analyzing a core dump is possible but normally the last resort.
then you ask why it happens. this is impossible to answer
since i don't know what you have tried. you provide
no information here that i could use. please describe
what you have tried. perhaps attach an output file.
SIr the thing is that I ran one job on single core in serial. But It got killed 3 times. I could not find it in tmp or in my directory where the icomplete output should come.

bast
Posts: 1210
Joined: 26 Aug 2013, 13:22
First name(s): Radovan
Last name(s): Bast
Affiliation: none
Country: Germany

Re: Installing Dalton on Ubuntu

Post by bast » 10 Jun 2014, 08:45

hi,
with the mpirun command i worry about the spaces in the path.
then with the output file that got lost, run dalton with -o option, then it writes
the output file to the submit directory and you always have it and can follow
it while dalton computes.
radovan

varuniitr
Posts: 69
Joined: 26 Mar 2014, 10:28
First name(s): Varun
Last name(s): Kundi
Affiliation: IIT Roorkee
Country: India

Re: Installing Dalton on Ubuntu

Post by varuniitr » 10 Jun 2014, 10:14

Radhovan Sir,
I am using nohup mpirun -np 8 Machinefile ./Hostfile /home/user/SOFT/DALTON/DALTON 2013.2 Source/build/dalton beta 10dft &
for running job on multinodes with 4 cores on each node. but job is getting failed. Is this script line correct? My job on single node with multocores is running. Job is running on local node but on other node it is not running. I am using Intel Cluster Studio. Please tell me solution.

bast
Posts: 1210
Joined: 26 Aug 2013, 13:22
First name(s): Radovan
Last name(s): Bast
Affiliation: none
Country: Germany

Re: Installing Dalton on Ubuntu

Post by bast » 10 Jun 2014, 10:33

sorry i read your first question too quickly but fortunately you asked me again.
this is not correct. you can either run the dalton.x binary with mpirun
or (preferably) run the dalton script which will run dalton.x with mpirun for you.
what you want to use is dalton -N. see the help text with dalton -h.

varuniitr
Posts: 69
Joined: 26 Mar 2014, 10:28
First name(s): Varun
Last name(s): Kundi
Affiliation: IIT Roorkee
Country: India

Re: Installing Dalton on Ubuntu

Post by varuniitr » 10 Jun 2014, 11:36

Radovan Sir,
As you said I compiled openmpi-1.8.1.tar.gz using
./configure CC=gcc CXX=g++ FC=gfortran F90=gfortran --prefix=/path
make all install

and configured DALTON using script as given on website
./setup --fc=mpif90 --cc=mpicc --cxx=mpicxx

While making the following error is coming into picture again.
I am using 32 bit ubuntu 12.04 LTS.
Please help me to install DALTON.

/home/user/MPI/DALTON-2013.2-Source/DALTON/abacus/her2fck.F:514.23:

& offset_mat,
1
Error: Type mismatch in argument 'idispl' at (1); passed INTEGER(8) to INTEGER(4)
make[2]: *** [CMakeFiles/dalton.dir/DALTON/abacus/her2fck.F.o] Error 1
make[1]: *** [CMakeFiles/dalton.dir/all] Error 2
make: *** [all] Error 2
user@ProLiant-ML370-G5:~/MPI/DALTON-2013.2-Source/build$ ^C
user@ProLiant-ML370-G5:~/MPI/DALTON-2013.2-Source/build$

varuniitr
Posts: 69
Joined: 26 Mar 2014, 10:28
First name(s): Varun
Last name(s): Kundi
Affiliation: IIT Roorkee
Country: India

Re: Installing Dalton on Ubuntu

Post by varuniitr » 10 Jun 2014, 11:46

bast wrote:sorry i read your first question too quickly but fortunately you asked me again.
this is not correct. you can either run the dalton.x binary with mpirun
or (preferably) run the dalton script which will run dalton.x with mpirun for you.
what you want to use is dalton -N. see the help text with dalton -h.
Sir Can you please write the example script line for Multinode calculation with mpirun?

bast
Posts: 1210
Joined: 26 Aug 2013, 13:22
First name(s): Radovan
Last name(s): Bast
Affiliation: none
Country: Germany

Re: Installing Dalton on Ubuntu

Post by bast » 10 Jun 2014, 13:02

for customized mpirun calculation you have 3 options as far as i can see:
1) you run dalton.x directly using mpirun and then you have full freedom
to specify machinefile etc. for this please consult mpirun documentation. note that input files in this case have to be called DALTON.INP and MOLECULE.INP
2) you edit the dalton script
3) you wait few days until we release the 2013.3 patch where one can export DALTON_LAUNCHER (and LSDALTON_LAUNCHER)
environment variable, example: export DALTON_LAUNCHER="mpirun -np=24 -hostfile myhostfile"

bast
Posts: 1210
Joined: 26 Aug 2013, 13:22
First name(s): Radovan
Last name(s): Bast
Affiliation: none
Country: Germany

Re: Installing Dalton on Ubuntu

Post by bast » 10 Jun 2014, 13:05

varuniitr wrote:Radovan Sir,
As you said I compiled openmpi-1.8.1.tar.gz using
./configure CC=gcc CXX=g++ FC=gfortran F90=gfortran --prefix=/path
make all install

and configured DALTON using script as given on website
./setup --fc=mpif90 --cc=mpicc --cxx=mpicxx

While making the following error is coming into picture again.
I am using 32 bit ubuntu 12.04 LTS.
Please help me to install DALTON.

/home/user/MPI/DALTON-2013.2-Source/DALTON/abacus/her2fck.F:514.23:

& offset_mat,
1
Error: Type mismatch in argument 'idispl' at (1); passed INTEGER(8) to INTEGER(4)
make[2]: *** [CMakeFiles/dalton.dir/DALTON/abacus/her2fck.F.o] Error 1
make[1]: *** [CMakeFiles/dalton.dir/all] Error 2
make: *** [all] Error 2
user@ProLiant-ML370-G5:~/MPI/DALTON-2013.2-Source/build$ ^C
user@ProLiant-ML370-G5:~/MPI/DALTON-2013.2-Source/build$
just checking: are you sure that mpif90 resolves to the one you just installed?
check:

Code: Select all

$ which mpif90

varuniitr
Posts: 69
Joined: 26 Mar 2014, 10:28
First name(s): Varun
Last name(s): Kundi
Affiliation: IIT Roorkee
Country: India

Re: Installing Dalton on Ubuntu

Post by varuniitr » 10 Jun 2014, 14:32

bast wrote:
varuniitr wrote:
just checking: are you sure that mpif90 resolves to the one you just installed?
check:

Code: Select all

$ which mpif90
Its printing
/usr/bin/mpif90

bast
Posts: 1210
Joined: 26 Aug 2013, 13:22
First name(s): Radovan
Last name(s): Bast
Affiliation: none
Country: Germany

Re: Installing Dalton on Ubuntu

Post by bast » 10 Jun 2014, 15:40

is this the one you installed? try:

Code: Select all

$ mpif90 --version

varuniitr
Posts: 69
Joined: 26 Mar 2014, 10:28
First name(s): Varun
Last name(s): Kundi
Affiliation: IIT Roorkee
Country: India

Re: Installing Dalton on Ubuntu

Post by varuniitr » 11 Jun 2014, 02:21

bast wrote:is this the one you installed? try:

Code: Select all

$ mpif90 --version
user@ProLiant-ML370-G5:~$ mpif90 --version
GNU Fortran (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3
Copyright (C) 2011 Free Software Foundation, Inc.

GNU Fortran comes with NO WARRANTY, to the extent permitted by law.
You may redistribute copies of GNU Fortran
under the terms of the GNU General Public License.
For more information about these matters, see the file named COPYING

bast
Posts: 1210
Joined: 26 Aug 2013, 13:22
First name(s): Radovan
Last name(s): Bast
Affiliation: none
Country: Germany

Re: Installing Dalton on Ubuntu

Post by bast » 11 Jun 2014, 07:29

hi,

you have built OpenMPI with:

Code: Select all

./configure CC=gcc CXX=g++ FC=gfortran F90=gfortran --prefix=/path
make all install
i don't know whether "/path" is really "/path". if yes, then "which mpif90"
should give
/path/bin/mpif90
and not
/usr/bin/mpif90

and if it is not pointing to where you want it to point,
you need to set (in your .bashrc or similar; adapt to your /path):

Code: Select all

export PATH=/path/bin:$PATH
export LD_LIBRARY_PATH=/path/lib:$LD_LIBRARY_PATH
then try again "which mpif90".

it is possible to have many MPI installations within the same system
but you have to make sure that you select the right one with PATH and LD_LIBRARY_PATH.
see also abundant documentation on this on the web.

varuniitr
Posts: 69
Joined: 26 Mar 2014, 10:28
First name(s): Varun
Last name(s): Kundi
Affiliation: IIT Roorkee
Country: India

Re: Installing Dalton on Ubuntu

Post by varuniitr » 15 Jun 2014, 14:18

bast wrote:hi,

you have built OpenMPI with:

Code: Select all

./configure CC=gcc CXX=g++ FC=gfortran F90=gfortran --prefix=/path
make all install
i don't know whether "/path" is really "/path". if yes, then "which mpif90"
should give
/path/bin/mpif90
and not
/usr/bin/mpif90

and if it is not pointing to where you want it to point,
you need to set (in your .bashrc or similar; adapt to your /path):

Code: Select all

export PATH=/path/bin:$PATH
export LD_LIBRARY_PATH=/path/lib:$LD_LIBRARY_PATH
then try again "which mpif90".

it is possible to have many MPI installations within the same system
but you have to make sure that you select the right one with PATH and LD_LIBRARY_PATH.
see also abundant documentation on this on the web.

Sir I am using ubuntu 12.04LTS 32 bit.
I have installed openmpi-1.8.1.
I am attaching my .bashrc and .bash_aliases files.
paths to bin of openmpi-1.8.1 is
/home/user/MPI/openmpi-1.8.1/bin
I am unable to set the paths. Please help.
BASH_ALIASES IS

# .bash_aliases

# Get the aliases and functions
if [ -f ~/.bashrc ]; then
. ~/.bashrc
fi

# User specific environment and startup programs
export PATH=/home/user/MPI/openmpi-1.8.1/bin:$PATH
export LD_LIBRARY_PATH=/home/user/MPI/openmpi-1.8.1/bin/lib:$LD_LIBRARY_PATH

BASHRC IS

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
case $- in
*i*) ;;
*) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
# We have color support; assume it's compliant with Ecma-48
# (ISO/IEC-6429). (Lack of such support is extremely rare, and such
# a case would tend to support setf rather than setaf.)
color_prompt=yes
else
color_prompt=
fi
fi

if [ "$color_prompt" = yes ]; then
PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
;;
*)
;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
alias ls='ls --color=auto'
#alias dir='dir --color=auto'
#alias vdir='vdir --color=auto'

alias grep='grep --color=auto'
alias fgrep='fgrep --color=auto'
alias egrep='egrep --color=auto'
fi

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands. Use like so:
# sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
. ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
if [ -f /usr/share/bash-completion/bash_completion ]; then
. /usr/share/bash-completion/bash_completion
elif [ -f /etc/bash_completion ]; then
. /etc/bash_completion
fi
fi

bast
Posts: 1210
Joined: 26 Aug 2013, 13:22
First name(s): Radovan
Last name(s): Bast
Affiliation: none
Country: Germany

Re: Installing Dalton on Ubuntu

Post by bast » 15 Jun 2014, 14:30

before going into the .bashrc, please try this:

Code: Select all

$ export PATH=/home/user/MPI/openmpi-1.8.1/bin:$PATH
$ export LD_LIBRARY_PATH=/home/user/MPI/openmpi-1.8.1/bin/lib:$LD_LIBRARY_PATH
$ which mpif90
now mpf90 has to point to /home/user/MPI/openmpi-1.8.1/bin/mpif90.
if not, then no reason to look for problems in .bashrc.
once the above works, you need to find out why .bashrc is not read
or why the PATH is not as it should.
look at your PATH (echo $PATH). is your installed path there?
it is read from left to right so the "first" mpif90 from left "wins".

please read also this:
http://stackoverflow.com/questions/4154 ... nvironment

varuniitr
Posts: 69
Joined: 26 Mar 2014, 10:28
First name(s): Varun
Last name(s): Kundi
Affiliation: IIT Roorkee
Country: India

Re: Installing Dalton on Ubuntu

Post by varuniitr » 15 Jun 2014, 15:55

varunkundi@ProLiant-ML370-G5:~/SOFT/openmpi-1.8.1$ which mpif90
/home/varunkundi/SOFT/openmpi-1.8.1/bin/mpif90
should I configure dalton now using mpich or have to check something else?

varuniitr
Posts: 69
Joined: 26 Mar 2014, 10:28
First name(s): Varun
Last name(s): Kundi
Affiliation: IIT Roorkee
Country: India

Re: Installing Dalton on Ubuntu

Post by varuniitr » 15 Jun 2014, 16:07

Now this error is coming into the picture

varunkundi@ProLiant-ML370-G5:~/SOFT/DALTON-2013.2-Source$ ./setup --fc=mpif90 --cc=mpicc --cxx=mpicxx --prefix=/home/varunkundi/SOFT
Configuring system: Ubuntu
FC=mpif90 CC=mpicc CXX=mpicxx cmake -DENABLE_MPI=ON -DENABLE_SGI_MPT=OFF -DENABLE_OMP=OFF -DENABLE_64BIT_INTEGERS=OFF -DENABLE_CSR=OFF -DENABLE_SCALASCA=OFF -DENABLE_TIMINGS=OFF -DENABLE_XCFUN=OFF -DENABLE_STATIC_LINKING=OFF -DENABLE_SCALAPACK=OFF -DCMAKE_INSTALL_PREFIX=/home/varunkundi/SOFT -DCMAKE_BUILD_TYPE=release /home/varunkundi/SOFT/DALTON-2013.2-Source

CMake Error at /usr/share/cmake-2.8/Modules/CMakeDetermineFortranCompiler.cmake:31 (MESSAGE):
Could not find compiler set in environment variable FC:

mpif90.
Call Stack (most recent call first):
CMakeLists.txt:12 (project)


CMake Error: Error required internal CMake variable not set, cmake may be not be built correctly.
Missing variable is:
CMAKE_Fortran_COMPILER_ENV_VAR
CMake Error: Error required internal CMake variable not set, cmake may be not be built correctly.
Missing variable is:
CMAKE_Fortran_COMPILER
CMake Error: Could not find cmake module file:/home/varunkundi/SOFT/DALTON-2013.2-Source/build/CMakeFiles/CMakeFortranCompiler.cmake
CMake Error: Error required internal CMake variable not set, cmake may be not be built correctly.
Missing variable is:
CMAKE_C_COMPILER_ENV_VAR
CMake Error: Error required internal CMake variable not set, cmake may be not be built correctly.
Missing variable is:
CMAKE_C_COMPILER
CMake Error: Could not find cmake module file:/home/varunkundi/SOFT/DALTON-2013.2-Source/build/CMakeFiles/CMakeCCompiler.cmake
CMake Error: Error required internal CMake variable not set, cmake may be not be built correctly.
Missing variable is:
CMAKE_CXX_COMPILER_ENV_VAR
CMake Error: Error required internal CMake variable not set, cmake may be not be built correctly.
Missing variable is:
CMAKE_CXX_COMPILER
CMake Error: Could not find cmake module file:/home/varunkundi/SOFT/DALTON-2013.2-Source/build/CMakeFiles/CMakeCXXCompiler.cmake
CMake Error: CMAKE_Fortran_COMPILER not set, after EnableLanguage
CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage
CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
-- Configuring incomplete, errors occurred!

varuniitr
Posts: 69
Joined: 26 Mar 2014, 10:28
First name(s): Varun
Last name(s): Kundi
Affiliation: IIT Roorkee
Country: India

Re: Installing Dalton on Ubuntu

Post by varuniitr » 15 Jun 2014, 16:23

this error has been resolved. now building is in process.

bast
Posts: 1210
Joined: 26 Aug 2013, 13:22
First name(s): Radovan
Last name(s): Bast
Affiliation: none
Country: Germany

Re: Installing Dalton on Ubuntu

Post by bast » 15 Jun 2014, 16:25

can you please describe what the solution was? normally the error means
that the file behind "which mpif90" does not exist.

varuniitr
Posts: 69
Joined: 26 Mar 2014, 10:28
First name(s): Varun
Last name(s): Kundi
Affiliation: IIT Roorkee
Country: India

Re: Installing Dalton on Ubuntu

Post by varuniitr » 15 Jun 2014, 16:31

same error. please help
/home/varunkundi/SOFT/DALTON-2013.2-Source/DALTON/abacus/her2fck.F:515.23:

& offset_mat,
1
Error: Type mismatch in argument 'idispl' at (1); passed INTEGER(8) to INTEGER(4)
make[2]: *** [CMakeFiles/dalton.dir/DALTON/abacus/her2fck.F.o] Error 1
make[1]: *** [CMakeFiles/dalton.dir/all] Error 2
make: *** [all] Error 2

bast
Posts: 1210
Joined: 26 Aug 2013, 13:22
First name(s): Radovan
Last name(s): Bast
Affiliation: none
Country: Germany

Re: Installing Dalton on Ubuntu

Post by bast » 15 Jun 2014, 18:06

can you please send the output of this (in your build directory):

Code: Select all

grep MPI_Fortran CMakeCache.txt

varuniitr
Posts: 69
Joined: 26 Mar 2014, 10:28
First name(s): Varun
Last name(s): Kundi
Affiliation: IIT Roorkee
Country: India

Re: Installing Dalton on Ubuntu

Post by varuniitr » 15 Jun 2014, 19:38

bast wrote:can you please send the output of this (in your build directory):

Code: Select all

grep MPI_Fortran CMakeCache.txt
MPI_Fortran_COMPILER:FILEPATH=/home/varunkundi/SOFT/MPICH/bin/mpif90
MPI_Fortran_COMPILE_FLAGS:STRING=
MPI_Fortran_INCLUDE_PATH:STRING=/home/varunkundi/SOFT/MPICH/include;/home/varunkundi/SOFT/MPICH/include
MPI_Fortran_LIBRARIES:STRING=/home/varunkundi/SOFT/MPICH/lib/libmpifort.so;/home/varunkundi/SOFT/MPICH/lib/libmpi.so;/usr/lib/i386-linux-gnu/librt.so;/usr/lib/i386-linux-gnu/libpthread.so
MPI_Fortran_LINK_FLAGS:STRING= -Wl,-rpath -Wl,/home/varunkundi/SOFT/MPICH/lib -Wl,--enable-new-dtags
//Details about finding MPI_Fortran
FIND_PACKAGE_MESSAGE_DETAILS_MPI_Fortran:INTERNAL=[/home/varunkundi/SOFT/MPICH/lib/libmpifort.so;/home/varunkundi/SOFT/MPICH/lib/libmpi.so;/usr/lib/i386-linux-gnu/librt.so;/usr/lib/i386-linux-gnu/libpthread.so][/home/varunkundi/SOFT/MPICH/include;/home/varunkundi/SOFT/MPICH/include][v()]
//ADVANCED property for variable: MPI_Fortran_COMPILER
MPI_Fortran_COMPILER-ADVANCED:INTERNAL=1
//ADVANCED property for variable: MPI_Fortran_COMPILE_FLAGS
MPI_Fortran_COMPILE_FLAGS-ADVANCED:INTERNAL=1
//ADVANCED property for variable: MPI_Fortran_INCLUDE_PATH
MPI_Fortran_INCLUDE_PATH-ADVANCED:INTERNAL=1
//ADVANCED property for variable: MPI_Fortran_LIBRARIES
MPI_Fortran_LIBRARIES-ADVANCED:INTERNAL=1
//ADVANCED property for variable: MPI_Fortran_LINK_FLAGS
MPI_Fortran_LINK_FLAGS-ADVANCED:INTERNAL=1

varuniitr
Posts: 69
Joined: 26 Mar 2014, 10:28
First name(s): Varun
Last name(s): Kundi
Affiliation: IIT Roorkee
Country: India

Re: Installing Dalton on Ubuntu

Post by varuniitr » 15 Jun 2014, 19:44

bast wrote:can you please describe what the solution was? normally the error means
that the file behind "which mpif90" does not exist.
Yes the thing is that after sometime which mpif90vdoes not give any path. Then I again exported the path and problem got solved.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests