cmake 2.8 required

Problems with Dalton installation? Find answers or ask for help here
Post Reply
preinhardtde
Posts: 3
Joined: 12 Nov 2013, 19:19
First name(s): Peter
Last name(s): REINHARDT
Affiliation: University Pierre et Marie Curie, Paris
Country: France

cmake 2.8 required

Post by preinhardtde » 12 Nov 2013, 19:27

Dear all,
trying to configure Dalton 2013 on a Linux machine running CentOS 5 or Rocks I run into troubles with the
version of cmake. Dalton requires version 2.8, but the most recent I can update for these Linux flavours
is 2.6.4. Is there a way to build Dalton with an older version of cmake ? The machines are not that old, and I am
not really keen on reinstalling my whole cluster.

Sincerely yours,
Peter Reinhardt
--
Maître de Conférences (HDR), Lab. Chimie Théorique,
Université P et M Curie, Paris, France
Web: http://www.lct.jussieu.fr/pagesperso/reinh

arnfinn
Posts: 231
Joined: 28 Aug 2013, 08:02
First name(s): Arnfinn
Middle name(s): Hykkerud
Last name(s): Steindal
Affiliation: UiT
Country: Norway
Location: UiT The Arctic University of Norway

Re: cmake 2.8 required

Post by arnfinn » 12 Nov 2013, 20:20

According to this page you can install cmake 2.8.10.2 or older on CentOS 5. Have you tried that?

preinhardtde
Posts: 3
Joined: 12 Nov 2013, 19:19
First name(s): Peter
Last name(s): REINHARDT
Affiliation: University Pierre et Marie Curie, Paris
Country: France

Re: cmake 2.8 required

Post by preinhardtde » 12 Nov 2013, 20:49

Thanks, this seems to work fine !
Yours,
Peter
--
Maître de Conférences (HDR), Lab. Chimie Théorique,
Université P et M Curie, Paris, France
Web: http://www.lct.jussieu.fr/pagesperso/reinh

alexender

Re: cmake 2.8 required

Post by alexender » 24 Nov 2014, 10:30

not really keen on reinstalling my whole cluster. .......!

bast
Posts: 1210
Joined: 26 Aug 2013, 13:22
First name(s): Radovan
Last name(s): Bast
Affiliation: none
Country: Germany

Re: cmake 2.8 required

Post by bast » 24 Nov 2014, 10:32

alexender wrote:not really keen on reinstalling my whole cluster. .......!
... which is not needed.

"installing" cmake is basically just downloading precompiled binaries
and setting the PATH variable.
see also here:
http://daltonprogram.org/installation/2 ... or-too-old

saisudhakar
Posts: 12
Joined: 13 Nov 2015, 05:49
First name(s): Saisudhakar
Last name(s): Mukka
Affiliation: Birla Institute of Technology and Science
Country: India

Re: cmake 2.8 required

Post by saisudhakar » 13 Nov 2015, 08:12

I am also trying to install DALTON on our centOS 5 linux system. It is asking CMake2.8. Now I have CMake 2.6.4. How to get the CMake2.8 or higher version ?

bast
Posts: 1210
Joined: 26 Aug 2013, 13:22
First name(s): Radovan
Last name(s): Bast
Affiliation: none
Country: Germany

Re: cmake 2.8 required

Post by bast » 13 Nov 2015, 09:15

saisudhakar wrote:I am also trying to install DALTON on our centOS 5 linux system. It is asking CMake2.8. Now I have CMake 2.6.4. How to get the CMake2.8 or higher version ?
please have a look here:
http://dalton-installation.readthedocs. ... or-too-old

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests