LSDalton not installing

Problems with Dalton installation? Find answers or ask for help here
Post Reply
michaljz
Posts: 7
Joined: 15 Nov 2013, 11:46
First name(s): Michal
Last name(s): Jaszunski
Affiliation: ICHO PAN
Country: Poland

LSDalton not installing

Post by michaljz » 15 Nov 2013, 11:57

hi,
I tried to install on two computers using the default/standard setup and cmake. On one of them I got both
Dalton and LSDalton successfully installed, on the other Dalton is OK but compiling LSDalton I get
(end of the output produced):

[ 71%] Building Fortran object CMakeFiles/lsutillib_common.dir/LSDALTON/lsutil/ODType.F90.o
[ 71%] Building Fortran object CMakeFiles/lsutillib_common.dir/LSDALTON/lsutil/OverlapDistributionType.F90.o
[ 71%] Building Fortran object CMakeFiles/lsutillib_common.dir/LSDALTON/lsutil/memory.F90.o
f951: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugs.opensuse.org/> for instructions.
make[3]: *** [CMakeFiles/lsutillib_common.dir/LSDALTON/lsutil/memory.F90.o] Error 1
make[2]: *** [CMakeFiles/lsutillib_common.dir/LSDALTON/lsutil/memory.F90.o.provides] Error 2
make[1]: *** [CMakeFiles/lsutillib_common.dir/all] Error 2
make: *** [all] Error 2

I have not tried/used any extra options, since I do not really need LSDalton on this second computer. If this is of
any general interest and someone needs it I can provide some more info (e.g. output of the setup, but it looked OK)

and best regards,
Michal Jaszunski

tkjaer
Posts: 300
Joined: 27 Aug 2013, 20:35
First name(s): Thomas
Last name(s): Kjaergaard

Re: LSDalton not installing

Post by tkjaer » 19 Nov 2013, 14:07

As specified in the compiler output "internal compiler error"

This internal compiler error might be bypassed, but it is though without being able to reproduce the problem.

Best option is to submit a full bug report to the compiler company, as requested by the compiler.

you can specify to compile dalton.x only by using the command: "make dalton.x"

running the tests cases can also be limited to dalton testcases using the command: "ctest -L dalton"

Zeljka.San
Posts: 44
Joined: 13 Mar 2014, 16:24
First name(s): Zeljka
Last name(s): Sanader
Affiliation: University of Split
Country: Croatia

Re: LSDalton not installing

Post by Zeljka.San » 13 Mar 2014, 16:28

Hi, Michal,
I have the same problem as you did. Did you find solution?
Best regards,
Zeljka

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests