Page 1 of 1

Dalton 2016 - CMakeLists.txt missing

Posted: 02 Oct 2017, 11:06
by vlado
Hello everyone,
I tried to install Dalton 2016 - downloaded as .tar.gz, not cloning (cloning times out before finish).
The setup was done with intelMPI (so proper flags were set etc.) and seems to be OK (just Performing Test MPI_F90_I4 - Failed, but if I unset the --int64 then the MPI_F90_I4 fails). Anyway, after cd build and make I got:

Scanning dependencies of target check_external_timestamp_qfitlib
[ 0%] Built target check_external_timestamp_qfitlib
Scanning dependencies of target check_external_timestamp_gen1int
[ 0%] Built target check_external_timestamp_gen1int
Scanning dependencies of target gen1int
[ 0%] Creating directories for 'gen1int'
[ 1%] Performing download step for 'gen1int'

[ 1%] No patch step for 'gen1int'
[ 1%] No update step for 'gen1int'
[ 1%] Performing configure step for 'gen1int'
CMake Error: The source directory "/some-dir/dalton_2016/external/gen1int" does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.
make[2]: *** [external/gen1int-stamp/gen1int-configure] Error 1
make[1]: *** [gen1int/CMakeFiles/gen1int.dir/all] Error 2

-----
If I copy the CMakeLists.txt from the main dir to the one which is missing it (into /some-dir/dalton_2016/external/gen1int) then it gets just a tad further with make, but exits with errors as well, so I assume the CMakeLists.txt is not the one which should be there (in /some-dir/dalton_2016/external/gen1int)?

Sorry, maybe it is just a triviality, but I can't seem to find a way out...
Thank you for any help!
Best,
Vlado

Re: Dalton 2016 - CMakeLists.txt missing

Posted: 02 Oct 2017, 11:46
by magnus
Copying CMakeLists.txt will not work. Problem is that the download approach will not automatically download all the external modules, so these have to be downloaded manually. I'm not sure but I think it will work if you download each of the modules listed here: https://gitlab.com/dalton/dalton/tree/r ... 6/external. You can download the correct commit by clicking on the commit hash that is shown in the list (you don't need the one without a commit hash). Then you have to extract each in their respective subdirectory under external.

Re: Dalton 2016 - CMakeLists.txt missing

Posted: 03 Oct 2017, 08:54
by vlado
Thank you very much - seems to be working!
Only the --int64 appears to cause some trouble, but that may be just my compiler...
Anyway - you solved the issue which I posted, so thanks' again :)