I/O ERROR IN PUTWA2 - CCSD excitation energies

Find answers or ask questions regarding Dalton calculations.
Please upload an output file showing the problem, if applicable.
(It is not necessary to upload input files, they can be found in the output file.)

Post Reply
mcasanova
Posts: 7
Joined: 12 Mar 2019, 01:16
First name(s): Marcos
Last name(s): Casanova
Affiliation: University of Melbourne
Country: Australia

I/O ERROR IN PUTWA2 - CCSD excitation energies

Post by mcasanova » 12 May 2019, 11:48

Dear Dalton people :-)

I've been using Dalton for a while now trying to get excitation energies using CCSD and CCSDR(3) so far for different systems, but I found one that gives me an error (pNA).

With this system I am doing 3 different calculations:
CCSDR(3) with cc-pvDZ
CCSD with cc-pvTZ
CCSD with aug-cc-pvDZ

the first 2 ended without any problem, but for the last one I got the next error
I/O ERROR IN PUTWA2:
FILE:CCAOIN_1
UNIT: 1
IADR: -2132060523
LEN: 27729574

--- SEVERE ERROR, PROGRAM WILL BE ABORTED ---
Date and time (Linux) : Sun May 12 18:51:54 2019
Host name : r3446

@ MPI MASTER, node no.: 0
@ Reason: I/O ERROR IN PUTWA2.

Total CPU time used in DALTON: 35 minutes 15 seconds
Total wall time used in DALTON: 50 minutes 30 seconds


QTRACE dump of internal trace stack

========================
level module
========================
4 CC_DRV
3 CC
2 DALTON
1 DALTON main
========================
I used the same input for all of them and just changed the method and basis set. You can find a copy of the output attached to this topic.

This are also the resources I am asking for:
#PBS -l mem=64GB
#PBS -l jobfs=100GB
export MKL_NUM_THREADS=$PBS_NCPUS (1)
export WRKMEM=640000000

I thought that maybe is a memory problem?

Thanks for all :-)

Kind regards,

Marcos
Attachments
pNA.out
(224.48 KiB) Downloaded 11 times

User avatar
magnus
Posts: 480
Joined: 27 Jun 2013, 16:32
First name(s): Jógvan Magnus
Middle name(s): Haugaard
Last name(s): Olsen
Affiliation: Hylleraas Centre, UiT The Arctic University of Norway
Country: Norway

Re: I/O ERROR IN PUTWA2 - CCSD excitation energies

Post by magnus » 12 May 2019, 12:02

Looks like an integer overflow. Since you're using an old version of Dalton, I would recommend that you first of all try again using the latest Dalton2018.2 release. There have been some fixes in the CC code though it may not help in your situation. If this doesn't work then you will need to compile using 64-bit integers (add "--int64" option when running setup). Here it is important to note that this will break some functionality in Dalton, so when you run the tests after compilation, expect some tests to fail.

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests