MEMGET error in Dalton 2016.0

Find answers or ask questions regarding Dalton calculations.
Please upload an output file showing the problem, if applicable.
(It is not necessary to upload input files, they can be found in the output file.)

Post Reply
Posts: 78
Joined: 05 Apr 2016, 17:47
First name(s): Dawid
Last name(s): Grabarek
Affiliation: Wroclaw University of Technology
Country: Poland

MEMGET error in Dalton 2016.0

Post by Addiw7 » 11 Jan 2017, 20:34

Dear All,

So far I have been successfully using Dalton 2015. However I needed Dalton compiled with some changes in mxcent.h and qm3.h files so I compiled Dalton 2016.0.
Now, the issue I run into is related to memory allocation when running Dalton in parallel (see the attached files and especially the DALTON-batch-system.out one).
I call Dalton with

Code: Select all

dalton  -N 6 -mb  6000 DALTON.dal  MOLECULE.mol
and total memory for the job is 40 000 MB. This actually does not matter because I run into exactly the same issues if I use
-mb 15000 and 115 000 MB of total memory. What is more the same job in Dalton 2015 took much less memory.
On the other hand, when I run dalton sequential there is no problem with memory allocation.
I have used both intel-15.0 and intel-13.1 to compile Dalton 2016, with the same results. Is this specific to my OpenMPI version?

Best regards,

PS I have changed MXQM3 to 15000 in qm3.h and set MXCENT_QM = 1200 MXCENT = 15000 in mxcent.h
(5.55 KiB) Downloaded 379 times
(31.2 KiB) Downloaded 360 times
(4.55 KiB) Downloaded 366 times

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests