DALTON-2015.0 running tests failed

Problems with Dalton installation? Find answers or ask for help here
Post Reply
qinghua
Posts: 10
Joined: 10 May 2016, 12:39
First name(s): Qinghua
Last name(s): Wu
Affiliation: Anhui Normal University
Country: China

DALTON-2015.0 running tests failed

Post by qinghua » 10 May 2016, 14:14

Hi everybody, I compiled the parallel Dalton software using the following compilers: ./setup --fc=mpiifort --cc=mpiicc --cxx=mpiicpc, everything passed succesfully. I then tried "make test", but receive the following error message:93% tests passed, 43 tests failed out of 599.
The following tests FAILED:
59 - energy_lucita_gasci (Failed)
444 - LSlib/LSlib_cam_reg (Failed)
445 - LSlib/LSlib_cam_dfJ_admm (Failed)
454 - linsca/linsca_admm (Failed)
455 - linsca/linsca_admm_df (Failed)
457 - linsca/linsca_admm2 (Failed)
458 - linsca/linsca_admmQ (Failed)
459 - linsca/linsca_admmP (Failed)
460 - linsca/linsca_admmS (Failed)
461 - linsca/linsca_admmS-KT3X (Failed)
488 - LSint/LSDALTON_magderiv (Failed)
508 - LSint/LSDALTON_ethane_df_dft_molgrad (Failed)
509 - LSint/LSDALTON_ethane_dft_molgrad (Failed)
510 - LSint/LSDALTON_ethane_dft_disp (Failed)
511 - LSint/LSDALTON_ethane_dft_D2disp (Failed)
512 - LSint/LSDALTON_ethane_dft_D3disp (Failed)
513 - LSint/LSDALTON_ethane_dft_D3bjdisp (Failed)
544 - LSresponse/LSresponse_HF_esg (Failed)
547 - LSresponse/LSresponse_HF_molgra (Failed)
557 - LSresponse/LSresponse_DFT_esg (Failed)
558 - LSresponse/LSresponse_DFT_esg_LDA (Failed)
561 - LSresponse/LSresponse_DFT_molgra (Failed)
571 - geomopt/Excited_state_opt (Failed)
573 - geomopt/geoopt_constrain (Failed)
574 - geomopt/cartes_bfgs_min (Failed)
575 - geomopt/redint_bfgs (Failed)
576 - geomopt/redint_bofill_ts (Failed)
577 - geomopt/cartes_trilevel_newconv (Failed)
578 - geomopt/cartes_psb_min (Failed)
579 - ddynam/H2O_NHchain (Failed)
580 - ddynam/HCN_ddyn (Failed)
581 - ddynam/HF_vib (Failed)
582 - ddynam/H2O_fmd (Failed)
583 - dectests/decmp2_energy (Failed)
584 - dectests/decmp2_density (Failed)
585 - dectests/decmp2_gradient (Failed)
586 - dectests/decmp2_geoopt (Failed)
590 - dectests/fullccsd_3 (Failed)
591 - dectests/fullccsd_2 (Failed)
593 - dectests/reordertest (Failed)
594 - dectests/decmp2_gradient_debug (Failed)
596 - dectests/decmp2_counterpoise (Failed)
597 - dectests/decmp2_fragopt (Failed)
The attachement is the LastTest(2).log. Can anyone give some suggestions for me? Thank you!
Attachments
LastTest (2).log
(920.87 KiB) Downloaded 276 times

simensr
Posts: 182
Joined: 28 Aug 2013, 09:54
First name(s): Simen
Middle name(s): Sommerfelt
Last name(s): Reine
Affiliation: University of Oslo
Country: Norway

Re: DALTON-2015.0 running tests failed

Post by simensr » 11 May 2016, 09:09

Dear Qinghua,

There seems to be four different causes for errors here:

1. the dalton test case that fail is energy_lucita_gasci (the others are all lsdalton test cases). I don't know what causes this, but there is at least some indication in the log file

2. the dectests fails because they are only intended to be run with more than one process "DEC calculations using MPI require at least two MPI processes!". This can be fixed by eg.

export DALTON_NUM_MPI_PROCS=2
make test

3. the LSDALTON_magderiv fails due to some error in the magnetic derivative code

4. the rest fails due to an error in the geometrical derivative code

Problem 2 is easily fixed, and it looks like 3 and 4 are bugs. Whan compier version are you using?

mpiifort --version

Simen

qinghua
Posts: 10
Joined: 10 May 2016, 12:39
First name(s): Qinghua
Last name(s): Wu
Affiliation: Anhui Normal University
Country: China

Re: DALTON-2015.0 running tests failed

Post by qinghua » 11 May 2016, 13:33

Dear Simen,

Thank you for your reply! I'm just a novice in Unix. The mpiifor version is ifort (IFORT) 16.0.2 20160204. May i ask an stupid question? What is the difference

between export DALTON_NUM_MPI_PROCS=2 and export DALTON_LAUNCHER="mpirun -np 8? The mannual say that i can run dalton by script, can you

show me how to operate this?

Qinghu

bast
Posts: 1197
Joined: 26 Aug 2013, 13:22
First name(s): Radovan
Last name(s): Bast
Affiliation: none
Country: Germany

Re: DALTON-2015.0 running tests failed

Post by bast » 11 May 2016, 20:42

i recommend to use DALTON_LAUNCHER (in your example the only difference will be 2 vs. 8 MPI tasks).
DALTON_LAUNCHER is more general. i think sooner or later we will retire DALTON_NUM_MPI_PROCS.
until then you can achieve the same with either. the reason why DALTON_LAUNCHER is more general
is that the launcher could for instance be valgrind instead, or aprun (Cray) or another MPI wrapper.

simensr
Posts: 182
Joined: 28 Aug 2013, 09:54
First name(s): Simen
Middle name(s): Sommerfelt
Last name(s): Reine
Affiliation: University of Oslo
Country: Norway

Re: DALTON-2015.0 running tests failed

Post by simensr » 11 May 2016, 21:41

Ifort version 16 was released in 2016 and is not supported for dalton 2015. I can no longer remeber which versions we did support but I believe all 12, 13 and 14 versions.

There is a short introduction to running lsdalton on the forum:

http://daltonprogram.org/forum/viewtopic.php?f=15&t=61

The syntax for running dalton is more or less the same:

/path/to/build/dalton dalton_input_file.dal molecule_input_file.mol

qinghua
Posts: 10
Joined: 10 May 2016, 12:39
First name(s): Qinghua
Last name(s): Wu
Affiliation: Anhui Normal University
Country: China

Re: DALTON-2015.0 running tests failed

Post by qinghua » 12 May 2016, 04:06

Thanks bast and simensr. I re-compiled DALTON-2016.1 only energy_lucita_gasci failed. The attachment is the LastTest.log and energy_lucita_gasci.out.
Attachments
LastTest1.log
(62.6 KiB) Downloaded 313 times

qinghua
Posts: 10
Joined: 10 May 2016, 12:39
First name(s): Qinghua
Last name(s): Wu
Affiliation: Anhui Normal University
Country: China

Re: DALTON-2015.0 running tests failed

Post by qinghua » 15 May 2016, 04:19

Dear all,
I am using mpi for running job, but the job is getting failed. Receiving the following error message: ERROR: GRAC not implemented for parallel calculations. Please tell me solution. The attachment is the output file. Thank you!
Attachments
dft_ac_grac_N2_aug-cc-pVDZ.out
(26.9 KiB) Downloaded 303 times

taylor
Posts: 532
Joined: 15 Oct 2013, 05:37
First name(s): Peter
Middle name(s): Robert
Last name(s): Taylor
Affiliation: Tianjin University
Country: China

Re: DALTON-2015.0 running tests failed

Post by taylor » 15 May 2016, 06:58

I think you can take it as literal that the program cannot do what you are asking it to do in parallel. I know next to nothing about the DFT code in Dalton but I assume that the way this particular feature as written it is not parallelized and furthermore for whatever reason (possibly shared memory) cannot be parallelized.

Note that many DFT features are parallelized, by the way.

Best regards
Pete

qinghua
Posts: 10
Joined: 10 May 2016, 12:39
First name(s): Qinghua
Last name(s): Wu
Affiliation: Anhui Normal University
Country: China

Re: DALTON-2015.0 running tests failed

Post by qinghua » 16 May 2016, 02:48

Thank you Pete.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest