Compiling LSDALTON2016 with OpenACC enabled

Find answers or ask questions regarding LSDalton calculations
Post Reply
Posts: 10
Joined: 25 Jul 2017, 13:54
First name(s): Zoltan
Last name(s): Takacs
Affiliation: C4X Discovery
Country: United Kingdom

Compiling LSDALTON2016 with OpenACC enabled

Post by zozonmr » 12 Mar 2018, 16:37


I am trying to compile LSDALTON2016 with --gpu --cublas and I have downloaded and installed the pgi librarys including the OpenACC (all examples compiled and run fine). When I run the command

./setup --gpu --cublas --cxx=pgc++ --cc=pgcc --fc=pgfortran

I get an error from cmake saying:

"Expecting to find librt for libcudart_static, but didn't find it."

Well, the file clearly exists but cmake cannot locate it.
I tried to link (ln -s) it almost everywhere including locations in /usr/local/ and usr/ but somehow I didn't manage to find the place cmake is actually looking for this file. It is a bit weird because then later on it reports that:

Found CUDA: "location in LD_LIBRARY_PATH"

Is there a recipe on how to build LSDALTON with OpenACC? Where does cmake look for the CUDA libraries?


Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests