Although Dalton2018.1 has been successfully build by “setup --mpi", all the tests failed

Problems with Dalton installation? Find answers or ask for help here
Post Reply
xiongyan21
Posts: 170
Joined: 24 Sep 2014, 08:36
First name(s): yan
Last name(s): xiong
Affiliation: CENTRAL CHINA NORMAL UNIVERSITY
Country: China

Although Dalton2018.1 has been successfully build by “setup --mpi", all the tests failed

Post by xiongyan21 » 13 Feb 2019, 05:12

Dear All
Although DALton2018.1 has been successfully build by "setup --mpi", all the tests failed and a independently running of test of cc2dc_energy gave the following error
...
Open MPI tried to fork a new process via the "execve" system call but
failed. Open MPI checks many things before attempting to launch a
child process, but nothing is perfect. This error may be indicative
of another problem on the target host, or even something as silly as
having specified a directory for your application. Your job will now
abort.

Local host: ...
Application name: ...
Error: Permission denied
--------------------------------------------------------------------------
4 total processes failed to startexport DALTON_LAUNCHER="mpirun -np 4"

I used the following to compile
export USE_MPI=y
./setup --mpi
cd build
make -j8
Before the process of testing, I typed
export DALTON_LAUNCHER="mpirun -np 8"

The OS is Ubuntu18.04 and MPI is openmpi.
By the way, should MKL be additionally exported?
Very Best Regards!

User avatar
magnus
Posts: 471
Joined: 27 Jun 2013, 16:32
First name(s): Jógvan Magnus
Middle name(s): Haugaard
Last name(s): Olsen
Affiliation: Hylleraas Centre, UiT The Arctic University of Norway
Country: Norway

Re: Although Dalton2018.1 has been successfully build by “setup --mpi", all the tests failed

Post by magnus » 25 Mar 2019, 21:14

It seems to be a problem with your local setup rather than an issue in Dalton. At least the "Error: Permission denied" points in that direction.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests